Jump to content

[Game's Borked] Cannot Connect to Server


Banteris
 Share

Recommended Posts

Heya!
My experience so far, just downloaded the Eden Eternal client/patcher last night and now I cannot connect to either server. It says the server status is Online at time of writing, but Imma list a summary for each game version below for clarification.

  •  Eden Eternal (Awaken)
    OCT 15th around 9PM CST, first logged in and played for a good couple of hours, butter smooth, no problems at all. Tried to log in this morning and managed to get to the character select screen once, but every attempt after that resulted in a 'Could Not Connect to Sever' error.
  •  Eden Eternal Classic
    OCT 16th around 10AM CST, logged in just fine, ran around a bit and levelled. Closed game and retried Awaken, no dice. So, tried to log back in to Classic and now I keep getting the 'Could Not Connect to Sever' error, as well
  • What I've Done to Fix This: 
    Allowed the patcher/Launcher exe files thru firewall; as well as enabled Run as Administrator/Disabled Full-screen optimizations, Verified the gamefiles, tested with a VPN connected to France as another Tech Support post recommended. My internet speeds are fine, I am able to connect to a variety of other online games and such.

It appears that the games ran fine on the first launch and log-in and I'm unsure if something changed in my files to cause this error. 
I'm going to retry installing the game fresh now, but is there anyone else who has encountered this error; or maybe has some advice that I have not tried yet?

Thanks!

EDIT UPDATE: 
Patcher is giving me this error below!

90bad8f76446642a06eec820178e6536.png

Link to comment
Share on other sites

  • VGN GM

Connect your VPN through US as the server is located there not europe.

Not sure why you cannot connect as the server is running fine with no issues. Could be related to your anti-virus but I doubt it is as it would stop program execution and not connection.

Just because you can connect to other games doesn't mean you can connect to every game.

The patcher error just happens for some people and not everyone depends on what node you connect to. I get this error around 50% of the time when opening the patcher yet I have no issues when in game.

Sorry I cannot be of more help because I'm not really sure whats going on. The only thing I could suggest is try restarting your internet and make sure the VPN you are using is reliable and isn't just free garbage that you find online. The only other things I can recommend is the usual, Anti-Virus exceptions (entire folder is usually best).

Link to comment
Share on other sites

  • Banteris changed the title to [Ongoing Error] Cannot Connect to Server
1 hour ago, Jordan said:

Connect your VPN through US as the server is located there not europe.

Then my VPN is not necessarily needed then, as I am in the US. 
I was basing that knowledge off of the post made by DrDieLess stating that the server was in France, which I notice was last edited in 2018. lol

Quote

Could be related to your anti-virus but I doubt it is as it would stop program execution and not connection.

Correct, the patcher.exe and folder are all listed as Exceptions on my Windows Defender. And I have attempted logins with it turned off. It is also allowed through my firewall.

Quote

Just because you can connect to other games doesn't mean you can connect to every game.

I mostly mentioned that because a potential question that may have popped up was the integrity of my ISP connection, so I said that mostly to avoid comments regarding it.

Quote

The patcher error just happens for some people and not everyone depends on what node you connect to. I get this error around 50% of the time when opening the patcher yet I have no issues when in game.

I think what you are trying to express here is that the Access Violation error I get from launching the patcher.exe is just a 'quirk' and can be ignored. If so, great. Now the only problem remaining is the inability to connect to the server.

Quote

Sorry I cannot be of more help because I'm not really sure whats going on. The only thing I could suggest is try restarting your internet and make sure the VPN you are using is reliable and isn't just free garbage that you find online. The only other things I can recommend is the usual, Anti-Virus exceptions (entire folder is usually best).

That's unfortunate. Restarting the 'net didn't do anything, and the VPN isn't really the issue. AV exceptions are in place as I've mentioned above.

Guess I'll just make a post describing what I can see on my end and see if anyone has any ideas.

Link to comment
Share on other sites

200a8fde0370bd998a9fe065c6bbb240.png

THE BIG LIST OF I HAVE NO IDEA WHY I CANNOT CONNECT

  • Reinstalling the game allows me to log in ONCE, as soon as I log out, I am unable to re-log back into the game on both Awakening and Classic.
  • connect.ini, connect_classic.ini, and connects.ini display the following in order, just in case something is incorrect:
    connect.ini: Server=54.39.158.92,6543
    connect_classic.ini: Server=51.161.117.230,6543
    connects.ini: Stream01=54.39.158.92,6543
  • in the main.log file this is posted at the end of the file, after the video settings:
    Quote

    [Desc]PrecacheKFM : 254->447=193 MBytes 
    [Desc]PeriodMin : 1 
    [Desc]PeriodMax : 1000000 
    [Desc]MinSleepPeriod : 0.001588 
    [Desc]LoginServer IP: 54.39.158.92(54.39.158.92), Port 6543
     
    [Desc]connect ErrCode[10035]

     
    [Desc]Restore Desktop Resolution : 1920 x 1080 32Bits 75Hz 

     

  • error.txt shows the following (errors are bolded)
    Quote

    [Desc]ERROR!! Mission[3435] AcceptCommand[AcceptSRA 1 11] is incorrect
     
    [Desc]Init 3D System Success. 
    [Desc]LOG - Load Scene begin... 
    [Desc]Log - Load CZone: S099
     
    [Desc]Log - Load FSM Begin... 
    [Desc]Log - Load FSM GrassList... 
    [Desc]Log - Load FSM Object... 
    [Desc]Log - Load FSM End...
     
    [Desc]Log - Load Terrain Object Begin... 
    [Desc]Scene Object Total: 1657 
    [Desc]Log - Load Terrain Object End... Time=[0.359508]
     
    [Desc]LOG - Load Scene end... 
    [Desc]LOG - Load SMP begin... 
    [Desc]LOG - Load SMP end... 
    [Desc]LOG - Load PGP begin... 

    [Desc]ERROR : Load PGP Failed 
    [Desc]LOG - Load PGP end... 
    [Desc]LOG - Load Bullet begin... 
    [Desc]LOG - Load Bullet end... 

    [Desc][LOGIN] 
    [Desc]Cannot Connect to LoginSever IMsgLoginError

     
    [Desc]LOG - Free CZone begin... 
    [Desc]LOG - Free CZone end... 
    [Desc]LOG - Free PGP begin... 
    [Desc]LOG - Free PGP end... 
    [Desc]DESTORY APP

    Going to try opening port 6543 on my router, maybe that's a cause; but not sure why I'm able to get in once and then blocked from further attempts after each reinstall. Will update if this works.

Link to comment
Share on other sites

EDIT

This post USED to be a marker for success with port forwarding, but the game just went back to stubbornly not letting me connect.It even flatlines the network connection for my PC only, causing my signal to just flat out say 'no connection'. 
No idea what that indicates, but I've spent most of my day trying to figure this out by myself to no avail. \o/
Might just be my PC at this point and the game's just not working with Windows 10 or something, I've given up. The game beat me. You won, Eden Eternal private server.
I did have fun for the couple of hours that I did manage to play, at least.
Have fun ya'll. o/

Edited by Banteris
The game beat me and I'm buttmad
Link to comment
Share on other sites

  • Banteris changed the title to [Game's Borked] Cannot Connect to Server
  • VGN GM

Looking at the error code specifically this [Desc]connect ErrCode[10035]

This would appear to be related the socket the game is trying to use to connect to the server.

Spoiler
WSAEWOULDBLOCK
10035
 
          Resource temporarily unavailable.
This error is returned from operations on nonblocking sockets that cannot be completed immediately, for example recv when no data is queued to be read from the socket. It is a nonfatal error, and the operation should be retried later. It is normal for WSAEWOULDBLOCK to be reported as the result from calling connect on a nonblocking SOCK_STREAM socket, since some time must elapse for the connection to be established.
 
https://docs.microsoft.com/en-us/windows/win32/winsock/windows-sockets-error-codes-2

So one guess I would make based on this post you made here:

 

Is that maybe there is some form of conflict between the two applications. I would maybe try reinstalling discord or checking the settings as there could be a port issue or something as I know many players use discord for their guilds so I'd have to presume the conflict is due to the configuration of your discord maybe? I personally don't really use discord much but I have had the game and discord open at the same time without issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...